Go Back   The Quad4Forums > Engine Specific Discussion > Quad 4/Twin Cam Problems > 2.4l Twin Cam Problems
Reply
 
Thread Tools Display Modes
  #1  
Old 12-19-2011, 02:56 PM
Bailey69's Avatar
Bailey69 is offline
Bailey69
Registered User*
Join Date: Dec 2011
Posts: 2
Make: Pontiac
Model: Sunfire GT
Engine: 2.4 Twin Cam
98 Sunfire GT Cranks But Wont start!

So glad I found this site. My gf gave me her 98 Sunfire GT because it quit running. (Thanks hun!) She said she tried to start it but the starter just clicked so her dad bought a new battery.Did the same thing after that. So that was two years ago. I put in a Optima Red Top I have and it cranks over but doesn't start. I remove the airbox and spray some starter fluid into the throttlebody and it tries to fire but never does. I try to hook up a OBD scan tool to see if there are any codes but it won't even send power to the scanner. I check the fuses to the PCM and they are all good. The check engine light lights up on the dash as do the security light and all the other warning lights. I have no clue what is wrong with it. I would appreciate any help from you all.
Reply With Quote
  #2  
Old 12-19-2011, 08:41 PM
p8ntman442's Avatar
p8ntman442 is offline
p8ntman442
Send a message via AIM to p8ntman442 who knows what wrong
Join Date: Apr 2003
Location: connecticut
Posts: 2,756
Classifieds Rating 100% (2)
Make: 2.3 quad 4 w41
Model: oldsmobile
Engine: calais
2 year old gas is surely bad, you will need to flush that out and ensure there is pressure in the system. A pump can go bad sitting that long and getting gummed up.

If you find you have fuel pressure, you need to check spark. Pull the ignition cover off, and get some spare plug wires (if you have a red top, you must have some mechanical ability/spare parts). Run the plug wires from the ignition housing down to the plugs, and put a spark plug tester in line of one. Crank it over, or have your GF crank it over for you and see if you have spark.

Report back when you know about fuel and spark.

Also your ECM not responding to the code reader is very troublesome. Check the plugs on the ECM for corrosion, also check the engine grounds on the block, typically if the fuel pump runs your engine grounds are good though.
__________________

Diagnose your rough running QUAD.
http://www.quad4forums.com/forums/sh...ad.php?t=18102

Engine specs
http://www.quad4forums.com/forums/techdata.php
Reply With Quote
  #3  
Old 12-20-2011, 12:09 AM
Bailey69's Avatar
Bailey69 is offline
Bailey69
Registered User*
Join Date: Dec 2011
Posts: 2
Make: Pontiac
Model: Sunfire GT
Engine: 2.4 Twin Cam
Thanks for your response. I will try what you told me asap. I did find that the reason I couldn't get any code reads from the PCM was because the port for the PCM runs off the same fuse as the cigarette lighter. I replaced the fuse but low and behold there were no stored codes anyway.
Reply With Quote
  #4  
Old 12-20-2011, 06:55 AM
Darkmage's Avatar
Darkmage is offline
Darkmage
Registered User
Join Date: Sep 2003
Location: Canal Winchester, OH
Posts: 1,237
Make: Pontiac
Model: 88 Fiero Notch
Engine: Quad 4 W-41+
Yea its very common for GM to run the DLC power (pin 16) on the same fuse as
the cigg lighter...
__________________
Electrical, Body systems, and Drivability Technician.
GM Dealership Technician. And now GM hybrid and Chevy volt certified.

88 Q4 Fiero
Reply With Quote
Reply

Bookmarks

Similar Threads
Thread Thread Starter Forum Replies Last Post
98 2.4, rattling on restart. Guest 2.4l Twin Cam General Discussion 6 11-12-2011 12:35 AM
Eddy's 99 Sunfire GT Eddy Member Rides 44 02-26-2011 09:53 AM
Sunfire GT 2.4l Performance parts??? Dynoray 2.4l Twin Cam Performance 11 03-03-2008 01:47 PM


Tags
cranks, start, sunfire



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 11:25 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright (C) quad4forums.com