Go Back   The Quad4Forums > Engine Specific Discussion > Quad 4/Twin Cam Problems > 2.4l Twin Cam Problems
Closed Thread
 
Thread Tools Display Modes
  #1  
Old 06-30-2006, 08:59 AM
2.4LZ24's Avatar
2.4LZ24 is offline
2.4LZ24
Registered User
Join Date: May 2006
Posts: 5
Make: chev
Model: Z24
Engine: 2.4L
Rough Idle??????

My 99 cav Z24 just started to idle rough today but no engine light came on, What are the causes and how could if fix it? thanks.
  #2  
Old 06-30-2006, 12:20 PM
VKZ24's Avatar
VKZ24 is offline
VKZ24
Track Junkie
Join Date: Jun 2006
Location: North Carolina
Posts: 9
Make: Chevrolet
Model: Z-24
Engine: 2.4L LD9
Quote:
Originally Posted by 2.4LZ24
My 99 cav Z24 just started to idle rough today but no engine light came on, What are the causes and how could if fix it? thanks.
First thing I would check is the 2" long hose on the TB that connects to the MAP. Mine had a hole in it a caused a bad idle. Next the TPS sensor if the hose is OK. Third the ignition coils under the IDI cover.
__________________
Vincent Keene
1998 Z-24 (w/ZR-1 brakes)
1996 Mazda Miata M-edition
1989 Nissan Sentra "General Lei"
  #3  
Old 06-30-2006, 01:43 PM
Iboc_C64's Avatar
Iboc_C64 is offline
Iboc_C64
Send a message via ICQ to Iboc_C64 Send a message via AIM to Iboc_C64 Send a message via MSN to Iboc_C64 Send a message via Yahoo to Iboc_C64 Green 97 GAGT 2.4L 5speed
Join Date: Jun 2006
Location: Farmington Maine
Posts: 312
Make: Pontiac
Model: Grand Am GT
Engine: 2.4L Twin Cam
You may not set a code immediately, It may have to run or idle for a while, mine didn't set any codes when I had a bad coil for the first week or so.
  #4  
Old 06-30-2006, 01:50 PM
VKZ24's Avatar
VKZ24 is offline
VKZ24
Track Junkie
Join Date: Jun 2006
Location: North Carolina
Posts: 9
Make: Chevrolet
Model: Z-24
Engine: 2.4L LD9
Quote:
Originally Posted by Iboc_C64
You may not set a code immediately, It may have to run or idle for a while, mine didn't set any codes when I had a bad coil for the first week or so.
In my experience the CEL isn't worth crap for engine problems. All it pretty much does is monitor the emissions stuff.
  #5  
Old 06-30-2006, 02:25 PM
Iboc_C64's Avatar
Iboc_C64 is offline
Iboc_C64
Send a message via ICQ to Iboc_C64 Send a message via AIM to Iboc_C64 Send a message via MSN to Iboc_C64 Send a message via Yahoo to Iboc_C64 Green 97 GAGT 2.4L 5speed
Join Date: Jun 2006
Location: Farmington Maine
Posts: 312
Make: Pontiac
Model: Grand Am GT
Engine: 2.4L Twin Cam
Pretty much, you cant rely on a CEL for diagnosing or for even determining that you even have a problem. I have seen people try to sell 2.4s with a terrble rod knock by saying "Its noisy, but it doesnt set a check engine light so it must be fine" yeah, bullshit.
  #6  
Old 06-30-2006, 08:00 PM
2.4LZ24's Avatar
2.4LZ24 is offline
2.4LZ24
Registered User
Join Date: May 2006
Posts: 5
Make: chev
Model: Z24
Engine: 2.4L
I checked that hose, its pretty dry rotted, I went to the dealer and it was $30.00, for that little hose, I couldent believe it. I got one on order now anyway, its going to take a couple of days for it to come in. Plugs were fine, coils are fine, everything looks pretty good except for that hose.
  #7  
Old 06-30-2006, 08:08 PM
MidniteXVZ's Avatar
MidniteXVZ is offline
MidniteXVZ
Registered User
Join Date: May 2005
Posts: 4,485
Make: dodge
Model: Stratus RT
Engine: 3.0 v6
OMG you could have picked up 5 feet of vacuume hose for like 10 bucks at napa! YIKES just tell em its for s BBC or similar heh
__________________
  #8  
Old 07-03-2006, 01:57 PM
misnblu's Avatar
misnblu is offline
misnblu
It lives
Join Date: Jan 2006
Location: Ocean Springs MS
Posts: 185
Make: Chevrolet
Model: Cavalier
Engine: 2.4 LD9
Talking

Quote:
Originally Posted by MidniteXVZ
OMG you could have picked up 5 feet of vacuume hose for like 10 bucks at napa! YIKES just tell em its for s BBC or similar heh
I had to do the same this weekend.
The hose was completely dry rotted but still sealed.
I replaced it with some vacuum hose and all is good in the land of GM.
To pay that much for a prebent hose is just too much.

Make it custom and it's usually cheaper.

Misnblu
__________________
Misnblu.com
^^^^^^^^
Closed Thread

Bookmarks

Similar Threads
Thread Thread Starter Forum Replies Last Post
2.3 idle rough esp at lower RPM's monyetbesar 2.3l Quad 4 Problems 14 08-23-2006 01:36 PM
Rough Idle Phantom GTZ 2.3l Quad 4 Performance 50 07-01-2005 05:40 PM
Rough Idle flood 2.3l Quad 4 General Discussion 8 03-31-2005 10:14 AM
Rough Idle after Rebuild Esmond 2.3l Quad 4 Problems 6 09-09-2003 11:34 PM
rough rough idle Fishy 2.3l Quad 4 Problems 11 08-11-2003 11:34 AM


Tags
idle, rough



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 11:30 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright (C) quad4forums.com